Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post
Offline Vwvix  
#1 Posted : 26 November 2021 10:43:51(UTC)
Vwvix


Rank: Newbie

Reputation:

Groups: Registered
Joined: 26/11/2021(UTC)
Posts: 3
United Kingdom
Location: England

I am absolutely desperate and hope that someone can help!!!!!
I have a 2013 manual VW Passat with a faulty ECU (EDC17). In February this year the car just would not start and it turned out that the ECU was water damaged. Dried it out and put it back in the car and everything was fine for a few months Then about 5 months ago the engine management light and airbag light came on a stayed on then 2 months ago the coil light started flashing and car kept going into limp mode. When checked it said it was turbo...sent turbo off and they sent it back as it was ok. Garage got a second hand ECU unit with same codes except it was from an automatic. Cloned ECU but cannot get the immobiliser codes from old one to replacement one. They ordered a pin thing that they thought would do the the immobiliser but it hasn't!! The car has been in the garage for 4 weeks and its back to the way it was before (lights on dash, limp mode, turbo code) and garage said they do not know what else to do!!!!
I am in the UK and am hoping that someone can help me with this problem or is it a case of I have to take it to VW and have to pay a fortune???
Sponsor
HexTag/HexProg tool is the ultimate tool for Ecu Cloning/Ecu Tuning including MDG1 Ecu Cloning/MDG1 Ecu Tuning, BDM Read/write, Key renew and EEPROM Reset

Click here on HexTag for more info about HexProg Software

Offline applerallph  
#2 Posted : 26 November 2021 11:53:51(UTC)
applerallph


Rank: Member

Reputation:

Groups: Registered
Joined: 08/02/2021(UTC)
Posts: 29
South Africa
Location: North West

Thanks: 16 times
Was thanked: 5 time(s) in 4 post(s)
..you can do IMMO OFF with hexprog online service if yu want to use the donor ecu (EDC17) no need of the pin thing that they thought would do immobiliser. What is the specific turbo code ?
Offline Vwvix  
#3 Posted : 26 November 2021 12:05:06(UTC)
Vwvix


Rank: Newbie

Reputation:

Groups: Registered
Joined: 26/11/2021(UTC)
Posts: 3
United Kingdom
Location: England

I believe it is P2563 but they took the turbo off and sent it away and they sent it back saying there was nothing wrong with it!
I am just at my wits end with it all since the ECU first went caput earlier this year. Everything is pointing towards it being the ECU (because it was water damaged) but they havent been able to do this immobiliser!
Offline Vwvix  
#4 Posted : 26 November 2021 13:15:02(UTC)
Vwvix


Rank: Newbie

Reputation:

Groups: Registered
Joined: 26/11/2021(UTC)
Posts: 3
United Kingdom
Location: England

I believe it is P2563 but they took the turbo off and sent it away and they sent it back saying there was nothing wrong with it!
I am just at my wits end with it all since the ECU first went caput earlier this year. Everything is pointing towards it being the ECU (because it was water damaged) but they havent been able to do this immobiliser!
Offline jokir  
#5 Posted : 27 November 2021 00:27:25(UTC)
jokir


Rank: Member

Reputation:

Groups: Registered
Joined: 29/12/2020(UTC)
Posts: 21
Slovakia
Location: Levice

Thanks: 3 times
Was thanked: 7 time(s) in 4 post(s)
Attach dump eeprom and flash original and donor ECU.
Or dump the CCM if the original ECU is damaged.
Offline Autohex_II_BMW  
#6 Posted : 27 November 2021 21:58:53(UTC)
Autohex_II_BMW


Rank: Advanced Member

Reputation:

Groups: Moderator
Joined: 22/08/2015(UTC)
Posts: 1,693
United Arab Emirates
Location: Dubai

Thanks: 637 times
Was thanked: 1527 time(s) in 829 post(s)
Originally Posted by: Vwvix Go to Quoted Post
I am absolutely desperate and hope that someone can help!!!!!
I have a 2013 manual VW Passat with a faulty ECU (EDC17). In February this year the car just would not start and it turned out that the ECU was water damaged. Dried it out and put it back in the car and everything was fine for a few months Then about 5 months ago the engine management light and airbag light came on a stayed on then 2 months ago the coil light started flashing and car kept going into limp mode. When checked it said it was turbo...sent turbo off and they sent it back as it was ok. Garage got a second hand ECU unit with same codes except it was from an automatic. Cloned ECU but cannot get the immobiliser codes from old one to replacement one. They ordered a pin thing that they thought would do the the immobiliser but it hasn't!! The car has been in the garage for 4 weeks and its back to the way it was before (lights on dash, limp mode, turbo code) and garage said they do not know what else to do!!!!
I am in the UK and am hoping that someone can help me with this problem or is it a case of I have to take it to VW and have to pay a fortune???


you can upload file online from your account on www.hexprog.com for immo off.
thanks 1 user thanked Autohex_II_BMW for this useful post.
Users browsing this topic
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.